Red led stays on after firmware update


#1

First: hi to all,

i hope i didn’t miss any topic or thread here, but i couldn’t find any information about my problem.

After firmware update the red led stays on and the tag is in some strange state. I can not receive any data from it and it is not in boot mode.

I’m able to switch the tag again into boot mode, therefore i can reproduce this.

Maybe some one can give me a hint.

Thank you :slight_smile:


#2

same problem for me with the ruuvi_firmware_1.2.8. I tried to flash 2 times with the same result.

I reflashed with the eddystone firmware which seems to work (produces 1 tiny red flash every second).

I didn’t try the espruino

Best regards


#3

Same thing. Does the RuuviBoot mode stay on after update completes?

I think the latest firmware might need fixing…


#4

Hello all,
Which RuuviTag version you’re running: Basic or Plus?


#5

Is this the basic version?


#6

It looks like to be a model plus. Could you please try this file and report if it works?
https://drive.google.com/open?id=1T7o_T0r6mA7H0eP8hj50QUlESR7We8Ij

Expected behavior is that the tag will flash red led a few time rapidly and then start broadcasting data. Also, could you look under the tag and tell the revision number? It should be a golden B3, B4, B5 or B6 near the nRF52.


#7

This version is B4.

Updated firmware v1.29 and red light still stays on. I did not see any blinking.

Eddystone version worked (red turned off), also the old 1.0.1 works if I re-flash it.


#8

Thank you for the details. Please keep on using 1.0.1 for now, we’ll follow up on this tomorrow.


#9

Sure.

Btw, long pressing button B lets me log into RuuviBoot again (green blinks and then red again). Not sure if it should, or was it thay pushing B and then R enables RuuviBoot mode?


#10

It sounds like the tag software manages to initialize the button, and button press tries to change the mode which will blink the green led. A bit later the tag will crash, restart the bootloader and notice the B is pressed thus entering the bootloader mode.

We’ll look into the possible causes of the error. @concerto51 and @JojoEffect: could you also report the tag version and behavior on 1.2.9? You can identify model basic by empty spots near the buttons.


#11

One more thing crossed my mind. Maybe you should add info to the firmware update page. More ppl might try updating after Lauri’s email today about new firmware version :slight_smile:


#12

Guys, thanks for the report. I just woke up and added a note to the DFU page. We’ll fix this as soon as possible and will update the page and this topic.


#13

Sorry for the late response, now i‘m on the bus to work and was able to flash version 1.2.9.

Same behavior again.

I have a B6.
I think it is a Ruuvi Basic.

By the way, with 2.2.1_alpha i had no Problems, if this helps :blush:


#14

It’s a plus model. Basic model has no sensors on it. If you’ve got another B6 unit, would be great if you could try if they behave exactly the same.


#15

On my second B6 it’s working.

So my current 3 Ruuvis are (not) running following versions:

  1. Ruuvi Plus B6 - FW v1.2.9 (not working) (former running 1.2.8 - not working, too)
  2. Ruuvi Plus B6 - FW v1.2.9 (working) (former running 1.0.1 - working)
  3. Ruuvi Plus B6 - FW v2.2.1_alpha (working) (former running 1.0.1 - working)

Hope this helps!
Thanks for your help!


#16

Okay, thanks. We just found a unit which has similar symptoms and are running tests on it. We’ll keep you posted.


#17

Update: Found a way to reproduce the issue. Fixing…


#18

Hello all,

We think we have found and fixed the issue. It seems that tags which have been running Eddystone or Espruino can have old configuration remaining which causes Ruuvi FW to crash.

Could you @JojoEffect @concerto51 and @Jaylingo please confirm if you have used other firmwares on tags with problems and try 1.2.11-beta out?

If it solves your issue we’ll do some more testing on the binary and update the release.


#19

I just flashed your 1.2.11-beta and now my Ruuvi Plus B6 is sending data.
I couldn’t test the payload, but both modes (RAW and Eddystone) are recognized in nRF Connect app.

Seems like you found the bug :wink:


#20

Hi

I flashed the 1.2.11 beta and my B4 plus advertises correctly (tested with ruuvi-station).

Previously I has flashed the eddystone and I think I tested the espruino a while ago (I don’t really remeber)

Thanks a lot.

waiting for the release