Red led stays on after firmware update


#21

I have now updated 5 of 6 ruuvi’s.
On my huawei, I can not see the zip files ruuvi_firmware_dfu_1.2.11-beta.zip or ruuvi_firmware_dfu_1.2.8.zip from nRF connect, but I can see them in files.

On my motorola, I have updated 5 of 6 ruuvi’s, but the nRF connect tries to initialize the last ruuvi, but it fails, and ruuvi is in green mode.

I have a file 20170920-ruuvi_fw.zip from September 28, which only works from my huawei.

All are B5s. Maybe I have tried Espruino.

Another thing, the mac address on this end on E3, the other one on an even number, eg D0.


#22

Hello,

The issue with your last Ruuvi sounds like the DFU connection is stuck in some strange state. You could try disconnecting the battery from RuuviTag and restarting Bluetooth on your phone and try update again.


#23

Restart of phone worked.


#24

The 1.2.11 version seems to fix the issue for everyone.
GitHub releases and lab.ruuvi.com/dfu are now updated.

Thank you everyone for your patience and helping us to resolve the problem quickly.


#25

Also having some trouble updating firmware: following the video, everything looked ok up to the time when the actual download should occur (red light continually on, nrf shows Ruuviboot NOT BONDED, clicked CONNECT, pressed DFU, got Select file type, OK’d Distribution packet (ZIP), shows ruuvi_firmware_dfu_1.2.12.zip), but when I click this line, I dont get a graphical progress page, but just a list of files - manifest.json, ruuvi_firmware.bin and ruuvi_firmware.dat. The red light has gone out, and the green light shows continuously. When I disconnect nrf, the red light comes on and stays on. Seems that the update has not succeeded.


#26

Just a PS to that last message: pressed B again, station resumed reporting but still with whole-number temperature, and no possibility of changing the temperature alert range (as before).


#27

Are you having one of the Kickstarter-era basic devices with no BME280 and LIS2DH12?


#28

The device normally reports temperature, humidity and pressure. I’m told that someone has used to accelerometer in another station in the same batch: does this mean that both BME280 and LIS2DH127 are both present? I’m using nRF Connect on a Samsung Galaxy J5.
The tag is a Kickstarter, I think. I notced that in the tutorial video the whole electronics can be lifted out of the case, but mine seems to have been glued in, and can’t be removed from the casing bottom half.


#29

Hello,

If you have one of the kickstarter RuuviTag+ units with BME280 and LIS2DH12 you should be good to go. Electronics are not glued, however the lubricant we used at the time with the O-ring will eventually harden and you’ll need to use a screwdriver to pop the casing open.

RuuviTag has 2 modes: RAW and URL. Kickstarter-era devices advertised in URL mode by default, 1.2.12 advertises in RAW mode by default. You can tell the mode by color of the led blinking: You should have red led blinking once per second. If not, press “B” to change the mode.


#30

Tried a few more alternatives, got to know nRF Connect a bit better, but otherwise no joy. There is obviously a connection between the smartphone and the Ruuvi Station, because the red led goes out and the green lights up and stays on. nRF says however Not Bonded. Is this important?. The zip file I have downloaded is ruuvi_firmware_dfu_1.2.12.zip and I select "Distribution packet (ZIP) from the list. But I don’t get that progress graph that’s shown in the video. All I get is the name of the zip file, and that’s it.
Under “Characteristics” of the Ruuvi nRF gives:
Device type: LE only
Adv, type: Legacy
Flags: GeneralDiscoverable, BrEdrNotSupported

To my newbie eye it looks as if although the devices are connected, the download from the phone to the station just doesn’t happen. The green led stays on until I press R again. Then the red led lights up, says lit for a moment, and then goes out, leaving the faint flashing green led and the station running as before. I have not been able to get the flashing red led you mention at any stage.

BTW about the glueing! The cover comes off without any trouble, but the electronics card itself cannot be removed from the case, as is shown in the video. One can still press the switches, though it’s not quite so easy as when the electronics card is removed from the case.


#31

Hello,

We have observed that some other BLE-programs running on the phone can prevent the update from succeeding. Try closing especially any BLE-sportswatch programs.

The tag is sometimes very tightly attached to the bottom with friction, however the tags have never been glued down in the enclosure. Try knocking the tag against a table or other surface to get it loose.