Node-RED Node


I think I followed and got the bluetooth node installed with no hassle, have you already tried that one?


Yep I have done that (and did it again), but even when copying code from

I do get flow but for bluetooth there’s just unknown scan ble

So seems it just isn’t working for me.


What hardware you are using? Which operating system?


@otso CHIP with debian jessie (headless).

I tried to install node via GUI of Node-RED Menu => Manage Palette and managed to install one BT from there. Now trying to remove that installed node ands reinstall it via GUI to see if it will appear to GUI like BT UART did when tried that just for testing purposes. Will report later

Edit: When adding node-red-contrib-noble via GUI it appears to Node-RED UI. Now just have to learn how to go forward. :slight_smile:


Ok, just devided to give testrun of one flow. When I deploy it I get message: Flows stopped due to missing node types. Check logs for details.

If I check with: sudo journalctl -f -u nodered -o cat

I see:
25 Jan 23:16:38 - [info] Stopping flows
25 Jan 23:16:38 - [info] Stopped flows
25 Jan 23:16:38 - [info] Waiting for missing types to be registered:
25 Jan 23:16:38 - [info] - scan ble

I see also 1 unused node which is hidden so cannot remove.

Anyway I will read things up at weekend or next week and hopefully will getthings working.

Thanks for all the help. Eventhought I finally got this far by trial & error method, but it’s always nice when someone tries to help. :slight_smile:

Edit: This is getting really annoying. I did got that node installed & appesaring at UI when installing via GUI at browser, like said earlier. BUT No when opening browser again and go to Node-RED, that node-red-contrib-noble is still installed when checking through GUI, but it’s not usable at Node-.RED UI.

So frustrating to fight against basic things. First node can be installed via command line like it should but doesn’t sppear at UI, then workaround to that and now this. I would like to use my time to study Node-RED & other things instead.:exploding_head:


Could you try with a Raspberry Pi 3 or a computer with built-in BLE or maybe with external BLE dongle?


At least I highly consider getting Raspberry Pi 3. Unless @tobru can give some more information about how he managed to get things working with CHIP cause for me everything almost works but then again not… :slight_smile:


Have a look here:


That’s the guide I followed, but can’t get things to work out. I put link here to CHIP forum where I’ve described the current situation and problem, so this won’t go too much offtopic. Possible solution should appear behind that link. :slight_smile:


I have been using node red to scan the ruvvitag tag message and it works great.

However, the lowest reliable start/stop timer that i have tried is 1s. Even so, i am still missing many raw data.

Eg, for a duration 1min, i am probably only getting ~20 data input

Are there other methods to get as much raw data from ruuvitag?


I’m having the same issue as huuhaa.

[info] Waiting for missing types to be registered:
[info] - scan ble

I used to have a working Ruuvitag setup (RPi3 + Nodered) but it stopped working suddenly, probably due to a update in something. node-red-contrib-noble is installed. Any ideas how to debug this?


I’ve noticed that Noble is broken on Mac OSX due to something in XPC connection, maybe this is related?


I have the same issue,

I cannot seem to add the ruuvitag node…

I am new at this world, can anyone help?


One thing I’ve noticed is that Noble fails to install on Rasbian / Node 10. I’m using NVM to pick Node 8.latest for now.


Thank you atso,
Can’t be sure how but managed to install the node (ruuvitag)

I just used npm install -g --production from the node folder.

now I am getting the string(53) error “Unable to start BLE scan. Adapter state: unauthorized”

… its a learning process I guess, a steep one :slight_smile:



Noble README has instructions on how to run without sudo


I can confirm this. Noble doesn’t work with Node 10.x only with 8.x on Raspberry…


Is anybody else experiencing problems with Noble? I had my Node-red flow running for days but now out of nowhere the Noble stays in state unknown and is unable to scan for devices. If I restart node red I will get the following:

[warn] [scan ble:aedb01e5.d1644] Unable to start BLE scan. Adapter state: unknown

Any idea how to get this working again?

Node is version 8.x so there should not be any problems.


Since I put this line in a startup script, I haven’t had problems.
sudo setcap cap_net_raw + eip $ (eval readlink -f which node)


Thank you for the reply. Isn´t that the command for allowing the root privileges to noble? What am I supposed to put in the which node part? I ran that as it is described on the instructions of noble:

sudo setcap cap_net_raw+eip $(eval readlink -f which node)

I have not had the unauthorized problem with my installation so I am not sure if the problem will be corrected by that line. But I will give it a try if I get some advice on how to determine the node.

Also I can get the flow to work again just by redeploying the flow again. I runs just fine for undetermined time and then stucks on scanning mode.