Humidity sensor incorrect value


I have 3 ruuvi, but one is giving the incorrect humidity, hardware error or software?



Could you please be more specific? How did you test the humidity values?


I have three Ruuvi, two give the same value , and one give a very low value (H52%,H52%,H8%).
and near i have a Broadlink A1(H51%). So i think that is a good test.

Thank you for the details. How are you checking the values? Are you using Android Nearby notifications, some Physical Web app, or maybe the Centria’s app? Could you share the URL from faulty tag so we can check the data decoding logic?

We have extended series of test in an environmental chamber running, and the tests should reveal any software faults in the sensors. If the fault is found in software, we’ll release an update package. If the issue is in sensor itself, we’ll send you a replacement.

I’m using IOS Fiscal web chrome this is the url
And are using the python scripts from in RPI3.

Thank you for the update.

Have you tried resetting the device, preferably by removing and reinserting the battery? It might be that something has failed in sensor initialization, and calibration coefficients would be corrupted.

If that does not help, I’d guess the fault is in the humidity sensor itself.

Hi, i finish to load the firmware using nRF Toolbox. I have remove the battery. And this are the values , 6% :frowning: not real
"DE:77:93:F9:C8:AE": {“humidity”: 6.0, “name”: “Office”, “temperature”: 24.0, “pressure”: 1019.0

Do you now i should proceed to return this?

I purchased 3 Ruuvis on Kickstarter and have used 2 of them so far with 1 of them giving massively different/low humidity readings. It’s usually 40 odd % wrong :grimacing:, i’ve reflashed the FW but it’s still the same and even took the cover off incase it was an airflow issue.

I haven’t tried taking the battery out yet but I don’t hold out much hope, I also need to check the third one to see how it performs.

Thank you for the report. We are looking into issues on humidity, and especially if there is a set of devices with the issue (bad batch of sensors?) or if all the devices have the same problem occasionally (software issue?).

@otso, It’s probably not related (since the error in the code is minor) but I’ve made an issue on Github regarding the calculation of humidity on the sensor.