Unable to update Ruuvi Tag firmware from v.3.30.4+default to v3.31.1 using iOS Ruuvi Station app version 0.7.6 (206)

When I tried to update the firmware by going to the “Update Firmware” screen for the tag, I saw a screen that said, “Latest available Ruuvi Firmware version: v3.31.1”, “Current version: Ruuvi FW v.3.30.4+default”. I clicked the “Start update process” button, then put the sensor to updating mode. Then I clicked the “Start update process” button. The green progress bar went from 0% to 100%, then the screen said, “Update successful”.

However, when I went to the “Update Firmware” screen again, I see the same message as before, “Latest available Ruuvi Firmware version: v3.31.1”, “Current version: Ruuvi FW v.3.30.4+default”.

I tried it again (why not?), but still got the same result.

Ideas?

Hello,

Thank you for the report. We’re looking into if we can replicate this somehow.

Hello,

Is It possible that the tag being updated is different one than the one you are looking at in Ruuvi Station? The app expects to find a tag in update mode, but iOS app does not verify that the tag being updated is the same one as the one selected in Station. It’s possible to have tags A and B, click update on A and end up updating B.

Yes, that’s quite possible. I just tried it again and the update worked fine, so I suppose that’s what happened.

Thanks for your helpful response and sorry for my confusion!

I presume you already know this, but it would be nice if the Ruuvi Station iOS app ensured that the tag that it’s updating is the same one that’s selected in the app.

I have similar problem with IOS and I have only one Ruuvi tag. I had version v3.28.12. I updated it with Ruuvi app, and when I go to update firmware, it tells I have version: ‘*

I tried the same with manual update using nRF connect app and manually downloading the latest firmware from: http://ruuvi.com/software-update/

Still the same firmware version listed: ‘*

And suggestion to update to v3.31.1

I installed the old firmware back and tried the above steps few times, but could not get to v3.31.1.

Anything that I can try further?

Hello,

Is the ‘* version shown in app update screen exactly like that?

If you scan the tag with NFC, what does the version number show?

It is exactly ’*, see screenshot.

Can you give instructions to me where to look for version number? I couldn’t spot anything directly that made sense to share unless you mean the info in manufacturer data: Ruuvi Innovations Ltd. <0x0499>

Hei,

nRF Connectilla version voi lukea valitsemalla “Connect” ja sitten “Device Information Service > Firmware version”.

NFC Tools -app näyttää version tekstikenttänä:

Se näyttää tuon saman: ’*

Ilmeisesti Tagin sisälle tallennettu versio on jotenkin korruptoitunut.

Jos Tag toimii hyvin, asialle ei tarvitse tehdä mitään. Jos Tagin toiminnassa on ongelma, ota yhteyttä sales@ruuvi.com ja toimitamme uuden laitteen takuuvaihtona ja tutkimme mikä tässä yksilössä on vikana.