Trouble connecting to used ruuvitags

Hi all,
I’ve bought a couple of used ruuvitags that were advertised as functional, but cannot connect in any way with the ruuvi station or the nRF connect

Removing the battery, pressing the reset or trying to go in bootloader mode ( R+B button) don’t affect the leds…they always stay on for 1-2 seconds and never blink

There is something I’m missing? What else I could check?


Have you tried putting new battery in to the devices? It’s possible that the batteries are at the end of their life and can boot the tag but don’t have enough power to operate radio anymore.

Otherwise it sounds like the firmware of tags has been changed, if you have equipment for wired connection you can restore the original factory firmware. .

Original user probably has more information about how tags have been used.

Hi Otso,
I measured both batteries and are about at 3.01V, so they should be fine
The seller didn’t mentioned about custom firmware, so I assumed they were ready to use, anyway I’m writing to him right now.
So in case they installed a custom firmware the only way to connect the ruuvitag and restore the original one is by using the devkit arduino shield?

Depends on the firmware, but if there is no bootloader you need SWD connection to tag. On older RuuviTags that practically requires the Ruuvi Devkit, on B6 and upwards you can use any SWD programmer with a Tag-Connect cable. has more information about the programming connectors.

I’ve checked and both are B6, nice to know that I can use other SWD programmer, I was already looking for the 6pin JTAG connector and the nRF52832 dev board.
This is a bit too much a “rabbit hole” for me, never expected to encounter those difficulties but I would like to resque the 2 Ruuvitag :slight_smile:
Anyway I’ll wait for a reply from the seller and then let you know as soon I’ve new info


1 Like

The seller shortly replied me that they should have the standard firmware, but at this point I’m not sure if trust him :face_with_raised_eyebrow:
I did a short video showing how the led turn on, trying to reset and going in bootloader mode…there is something that I can try before resorting to the wired connection?

1 Like

The serial number makes me think that the firmware is something else than standard Ruuvi Firmware, there isn’t really anything that would produce a 7 decimal digit serial on Ruuvi Firmware.

I can’t come up with anything else than flashing the original factory firmware on those tags, they seem to be fine visually.

Do you know what’s the origin of your batteries? 4.0 V seems really high for a li-ion coin cell, I don’t think I’ve ever measured over 3.5 V on any battery shipped by Ruuvi.

They are CR2477
I was pondering about the 4.0V, indeed too high, and in the end it was just a false reading from my multimeter (with an almost flat battery :slight_smile: )
Measured again and are 3.2 and 3.1V.
Anyway the batteries are not the issue, I’ve also tried to supply 3V using a lab power supply but din’t change anything

Thanks for the clarification, RuuviTags are rated to 3.6 V so I was a bit worried :slight_smile:

In the end I’ve decided to try the wired connection option
Since you mentioned that from B6 is possible to use any SWD programmer and I just need to restore the original firmware (not developing anything) do you have some cheap options to suggest?
Otherwise I’ll buy the Ruuvi DEVKIT, is a bit pricey for my need but as soon I recover the ruuvi I’ll probably sell it to other users.


A tag-connect cable + nRF52 devkit or other compatible SWD programmer works too. The official Segger JLink-programmers are rather pricey for one-offs. is the correct cable.

Thanks the swift reply Otso, I thought about it a bit about it and I’ll probably bite the bullet and buy the official Ruuvi devkit and a brand new Ruuvitag.
In the end this is the fastest way to have something to working with and go on with my project

Are there public coupons code active for a first time buy on the official shop?


We do not have any active coupons right now, but shipping is free for orders of over 100€ + VAT.

1 Like

update: I’ve received the devkit + 1 new ruuvitag (fast shipping!) today and now I’m trying to undestand how to flash the firmware.
I’ve to admit that I’ve almost no knowledge about C, compiling, hw debugging, ect so I’m a bit lost.

What I did until now:

  • ruuvi on the shield+devkit and connected via usb
  • installed Segger embedded studio
  • git cloned last ruuvi firmware from github and downloaded the Nordic Semiconductor SDK nRF5_SDK_15.3.0_59ac345 on project folder

I suppose I need to compile the firmware and then flash by using the “connect J-link” on SES, but when I try to build the project I get a missing file error from the main.c:
task_acceleration.h: No such file or directory

I’m on windows, do I need to switch on a unix environment?

You don’t need to compile the firmware yourself, you can use the ready binary

and Nordic Command Line Tools

nrfjprog --eraseall
nrfjprog --program ruuvi_firmware_full_2.5.9.hex
nrfjprog --reset

Be sure to power cycle the tag (remove battery) to make sure that the debug interface is turned off afterwards, otherwise your batteries will drain quickly. If the erase all command doesn’t work, you have confirmed that there’s some other firmware and you can run nrfjprog --recover

If you want to compile the firmware yourself, it should be doable on windows but it’s possible that project configuration needs to convert some / to \\ or \

1 Like

So it was easier than I thought :grinning:

In the end I managed to restore a ruuvitag with the alpha 3.17.1 firmware and SES (compiling worked fine with this version) by following this tutorial on lab.ruuvi
The other one restored flawlessy to 2.5.9 using the nrf command line you suggested, so both are now finally working!
Digging down into this I founded a lot of interesting posts and articles and tutorials (most written by you @otso) I guess I’ve a lot to study and play with in the next weeks
Thanks again for the support! :+1:

1 Like