Tag flashing red LED after firmware upgrade

Hello,

after I tried to update the firmware of my Ruuvi Tag using the Ruuvi Station android app (from a very old firmware, that wasn’t displayed in the app), it started flashing a red light. Repeated tries to update the firmware lead to the same result (the app reports that the update was successful). I also tried using the nRF app, but the update finishes “successfully” and the tag keeps flashing a red LED after the update is finished.

I also tried putting on fresh batteries, also without success.

Before (and after) I failed to update this one tag, I succeeded updating the firmware from 2 other tags of the same batch.

What does the flashing red LED mean? And how can I fix the tag?

Thanks in advance,
Ricardo

Hello Ricardo,

Red led flashing is usually a symptom of non-recoverable error in boot detected by tag self-test. It might be that a tag has a damaged sensor, that would also explain why Station app did not see the tag before update.

There isn’t much that can be done if the problem is damaged board, in theory it would be possible to connect a debugger to the tag to see what exactly is failing in the self-test and try to replace the component but that’s quite a bit of effort.

Is the RuuviTag board visually ok, or is there some discoloring on it?

Hello,

the tag was working properly and displaying sensor data before, what was missing was just the current version number when trying to update it.

There’s no visual sign of damage, and it was working prior to the “successful” update attempt.

And pictures of the tag attached.


Hello,

The board seems fine to me too. Sometimes there is a cold solder joint that fails when the tag is moved, it might be a visibly lifted component or invisible damage.

Please send email to sales@ruuvi.com and link this thread, we’ll figure out the next steps from there.

Can you enter RuuvTag to bootloader by pressing B (holding) and then R? And then try to update again using nRF Connect? https://ruuvi.com/software-update/

We have another report where tag is broken after the update but was able to enter bootloader and updated again. And it works again.

Yes, I tried that procedure too.

The tag does enter into bootloader, and the update seems to succeed, but when it reboots, the red LED starts blinking again.