Synkronointiongelma iOS:lla

Here is a video of how this problem https://www.kuikka.net/ruuvitag/ruuvi.mov
firmware and iOS app are latest versions

Thank you for the video.

The GATT connection goes through three phases in latest firmware.
First, the GATT connection opens up with default settings while phone and tag negotiate the connection parameters. This negotiation takes around 5 seconds, and I think data is transferred for those first 5 seconds.

Second, the connection switches over to high-performance mode which optimizes the data transfer rate and battery consumption. However, this mode is sensitive to connection quality and older phones don’t support the BLE features used for optimization, which leads to really slow data transfer in some cases. But there still should be new data coming in.

Third, after 30 seconds in high-performance mode the tag switches to reliable mode which consumes a lot of RuuviTag battery but should work in all conditions and with all phones.

It seems to me that the issue is in the second phase. Does the data transfer continue to third phase in half a minute or is the connection lost entirely?

@priyonto Let’s take a look into GATT parameter side of things. There are some things I can do in firmware, but we’d need a way to test the changes

1 Like

I just reseted my Tag so I have to wait 2-3 days for the problem to return. I’ll get back to you.

@meisseli I have checked the video. Does the syncing stay stuck like that forever? In my experience sometimes the sync could get stuck for few seconds and can slow down even for a while but it usually ends up being completed.

Sync stays like that at least for 4 minutes. After that I canceled sync.

Another thing I just noticed. First I tried syncing and Ruuvistation found 440 records. Then I pressed cancel and cleared memory and now it founds only 315 records. Yet another try and it found 601 records. Yet another try and 199 records and so on.

Thank you for the details. This definitely sounds like the issue is caused by connection parameter change.

Try to remove sensor and add it again?

I have done that but it doesn’t help