Smart Mirror ja ruuvitag ongelma

Hei

Ensimmäinen viesti täällä ja muutenkin nyyppä linuxin säätämisen kanssa.
Pahoittelut varmuuden vuoksi etukäteen. :wink:

Eli kyseessä on Raspberry Pi 4 jossa on Raspberry Pi IOS ja MagicMirror2 asennettuina.

Näiden suhteen kaikki on ok, mutta kun koetan asentaa ohjeiden mukaan ruuvitageille tarvittavia
juttuja tämän mukaan.


niin olen jumissa tässä kohdassa:

"Install ruuvitag-sensor package from the Python Package Index (PyPI) with pip (Python package management system). Because we are using Python 3, install ruuvitag-sensor package with pip3. Add --user to install for current user

$ sudo pip3 install --user ruuvitag-sensor"

Niin saan vaan tälläisen ilmoituksen:

“pip is configured with locations that require TLS/SSL, however the ssl module in Python is not available.
Collecting ruuvitag-sensor
Could not fetch URL https://pypi.python.org/simple/ruuvitag-sensor/: There was a problem confirming the ssl certificate: Can’t connect to HTTPS URL because the SSL module is not available. - skipping
Could not fetch URL https://www.piwheels.org/simple/ruuvitag-sensor/: There was a problem confirming the ssl certificate: Can’t connect to HTTPS URL because the SSL module is not available. - skipping
Could not find a version that satisfies the requirement ruuvitag-sensor (from versions: )
No matching distribution found for ruuvitag-sensor”

Help?

Moi,

Ehkä nämä ohjeet auttavat? https://medium.com/@dblume/getting-pip-working-for-python-3-7-on-rasbian-f414d9d526d0

Hei

Kiitos linkistä, tutkin sitä paremmalla ajalla kunhan yövuorot on ohi. (1 jäljellä)

Hei

Pihalla kuin lumiukko ja siellä sataa vettä…

pi@raspberrypi:~ $ sudo pip3 install --upgrade setuptools
pip is configured with locations that require TLS/SSL, however the ssl module in Python is not available.
Could not fetch URL https://pypi.python.org/simple/setuptools/: There was a problem confirming the ssl certificate: Can’t connect to HTTPS URL because the SSL module is not available. - skipping
Could not fetch URL https://www.piwheels.org/simple/setuptools/: There was a problem confirming the ssl certificate: Can’t connect to HTTPS URL because the SSL module is not available. - skipping
Requirement already up-to-date: setuptools in /usr/local/lib/python3.6/site-packages

pi@raspberrypi:~ $ openssl version
OpenSSL 1.1.1d 10 Sep 2019

pi@raspberrypi:~ $ sudo apt-cache policy libssl-dev
libssl-dev:
Installed: (none)
Candidate: 1.1.1d-0+deb10u4+rpt1
Version table:
1.1.1d-0+deb10u4+rpt1 500
500 http://archive.raspberrypi.org/debian buster/main armhf Packages
1.1.1d-0+deb10u4 500
500 http://raspbian.raspberrypi.org/raspbian buster/main armhf Packages

pi@raspberrypi:~ $ sudo apt install -t jessie-backports libssl-dev=1.0.2l-1~bpo8+1
Reading package lists… Done
E: The value ‘jessie-backports’ is invalid for APT::Default-Release as such a release is not available in the sources
pi@raspberrypi:~ $

Edit: Olen koettanut hieman tutkia itsekin asiaa, mutta kuinkahan kaukaa haettua/haku ammuntaa tämäkin on…

pi@raspberrypi:~ $ sudo apt-get install python3-setuptools
Reading package lists… Done
Building dependency tree
Reading state information… Done
python3-setuptools is already the newest version (40.8.0-1).
python3-setuptools set to manually installed.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Ja tuo olisi uusin versio setuptools-51.1.0.tar.gz

Jotenkin tuo liittyy siihen että Python haluaa hakea paketteja httpsllä mutta python-ympäristösi ei tue SSLää. Googlailemalla löyryy ohjeita jotka alkavat siitä että koko python käännetään lähdekoodeista, esimerkiksi https://stackoverflow.com/questions/45954528/pip-is-configured-with-locations-that-require-tls-ssl-however-the-ssl-module-in .

En osaa sanoa että mikä noista olisi oikea tai paras ratkaisu, mutta ilmeisesti ratkaisu kuitenkin on olemassa.

Sama ajatus on itselläkin pyörinyt päässä.

Kiitos avusta,
Hyvää Joulua!

OpenSSL> version
OpenSSL 1.1.1d 10 Sep 2019
OpenSSL>

hmmm…

Edit: Lieneeköhän jotain ongelmaa Pythonin asennuksessa, josta lähtöisin tuo alkuperäinen ongelma on?

Pätkä asennusvaiheen logista…

gcc -pthread -c -Wno-unused-result -Wsign-compare -DNDEBUG -g -fwrapv -O3 -Wall -std=c99 -Wextra -Wno-unused-result -Wno-unused-parameter -Wno-missing-field-initializers -Werror=implicit-function-declaration -fvisibility=hidden -I./Include/internal -I. -I./Include -DPy_BUILD_CORE -o Objects/tupleobject.o Objects/tupleobject.c
gcc -pthread -c -Wno-unused-result -Wsign-compare -DNDEBUG -g -fwrapv -O3 -Wall -std=c99 -Wextra -Wno-unused-result -Wno-unused-parameter -Wno-missing-field-initializers -Werror=implicit-function-declaration -fvisibility=hidden -I./Include/internal -I. -I./Include -DPy_BUILD_CORE -o Objects/typeobject.o Objects/typeobject.c

Edit2:

Taisin onnistua, Python 3.9.1 asennuksen yhteydessä.

Looking in links: /tmp/tmptdx_5y4x
Processing /tmp/tmptdx_5y4x/setuptools-49.2.1-py3-none-any.whl
Processing /tmp/tmptdx_5y4x/pip-20.2.3-py2.py3-none-any.whl
Installing collected packages: setuptools, pip
Successfully installed pip-20.2.3 setuptools-49.2.1

1 Like

Kyselin raspberry pi forumilta asiaa ja syy on tässä:

“Raspberry Pi OS has Python 3.7.3 by default so there would normally be no need to install an earlier 3.6 version.”

Hirveä säätö, pelkästään sen takia että noudatin ohjeita (juu siellä luki “optional”), mutta kun en tajunnut tarkastaa pythonin versiota ennenkuin aloin asentaa vanhempaa versiota…