'ruuvitag-sensor' permission problem on rPi3

#1

I use ruuvitag-sensor -package to interface with ruuvitags on raspberry pi 3 b +. Os is latest Raspbian stretch lite, kernel 4.14.98-v7+.

I got library’s examples working and started writing my own python program to get sensor data and save it to a database, no problems, yet. Since this program will be run automatically at specific times along with other programs I’d like to run it as normal user instead of root.

I tried following advice from this post https://f.ruuvi.com/t/unable-to-get-sensor-data/1015 , I have all required packages installed and executed the two given commands to grant needed permissions.

The program works fine when run with sudo. But still when I’m trying to run it as normal user, it first asks for my sudo passwd, but even after that it fails to get any data from tags, sensor.Update() just returns {}.
And the weird thing is that for example hcitool dev works now as a normal user.

Since the code works when executed with sudo I don’t think the problem is with code or library but some missing permission somewhere I just can’t figure out.

I have used linux couple of years but this is my first time messing with bluetooth so I’m pretty much lost at this point.
Any help is greatly appreciated.

#2

Hello,

Maybe you have installed the package as a root or with sudo, and the files are marked as owned by root?