Ruuvitag-logger and viewer on Raspberry Pi 3

Thanks for all the tips. I could read out the MAC under Android…

I am running the readymade image on raspberry pi 3 and reading the ruuvi.local on desktop att the same local network. Among other things i need to get this setup off the local network and in to a server. Ill work on that more later. This Grafana seems to be a wonderous thing. It may very well prove to be just the thing for my beehive sensors. (…If it can do a notification if temp rises suddenly)

I noticed that grafana updates the graphs immediately after i do hcitool lescan on the Pi (im not sure if it does update ever if I don`t do a scan, May just be my impatience :slight_smile: )

Has anyone else tried running the current ruuviberry image on a pi 3 B+ . I have had no problems with that image on a 3 B, but cannot boot successfully on the 3 B+. I flash the card with Etcher and have tried both flashing using Windows and flashing on a Mac.

The image is made on 3B, and since it is a binary image it is probably not compatible with 3B+

OK thanks for the quick reply. That makes some sense. I’ll pick up another 3B and use this 3B+ for something else.

I guess you can make it work by replacing start.elf on the card with one copied from latest Raspbian. At least that’s how it usually works.

Oh, and you might need a new kernel too to support the USB and Ethernet ports (the new chip).

My Rasp is Raspberry Pi 3 Model B V 1.2 and ruuviberry started fine from the latest image - ruuviberry_2018_04_18.img.
But the WLAN seems to be totally missing. The OS can’t even find any adapters. othervise the OS seems to be OK. Is this a bug or a feature?

This is a feature, the Raspberry should advertise itself as a “RuuviGW” hotspot. You can remove br0 which bridges the Ethernet and WiFi together.

1 Like

Sorry, I’m a newby in Rasbian world. Where exactly I ought to remove br0? Removing it from etc/network/interfaces make no difference and there are 416 files or directories named br0?

@Andre_Norrback Could you help here?

Finally looping back because I’m tired of being tethered. I tried a few resources, most directed me to the method shown here. When I hover over the network connection tray icon it says “br0: Departed,” and I have no network access even with an ethernet cable connected. Rebooting always results in br0 coming back. I recall also trying to edit the network configuration files with no luck. @otso or @Andre_Norrback can you help?


It’s probably easiest to setup the Pi from scratch with these instructions

1 Like

Great. Thanks. I had those instructions from scattered posts and it’s handy to have them in one place. Also maybe I’m missing out on some nice utility of the basal setup. What’s the purpose of having it set up as a hotspot?


The image is setup as a hotspot because it allows people to connect to it and view the data without finding the IP address of the Pi from a router or a network scan.

Hi Otso,
A real beginner here…
I have an Raspberry Pi 3 B+ and tried to follow the instructions that you linked to.
I installed the latest version of Rasbian Stretch release date 2018-10-09
Got Grafana and InfluxDB working toghter but I can not get RuuviCollector to work, I totally lost with with it.
Is it possible that someone can make an ISO image for me for the latest version of Pi?


We’ll update the image at some point, but I can’t promise exact schedule.
What is your issue with the RuuviCollector?

Tanks for fast replay.
My problem seems to be with HCIDump and HCITool. You have to remeber that I’m a totally green with this so there can other things also.
So perhaps the fastest solution for me would be to buy a P 2 or 3B?


Have you checked the instructions on how to run HCItool without sudo?

Jep, perhaps I will try to start allover again to be sure I got all other parts installed correct and not messed up with wrong paths and so

No luck with anything I tried…
Ruuviberry images, different versions… no luck
Installing one by one… no luck

So my question is: Is it the easiest way for me to buy Raspberry pi 2?