RuuviTAG ei suostu päivitysmoodiin lainkaan

Aloitin Tagieni päivityksen ja homma toimi hienosti ohjeiden mukaan. Yksi TAGi kuitenkin kieltäytyy menemästä lainkaan päivitysmoodiin.

Kun painan B+R nappeja ensin vilahtaa toinen ledi ja sitten toinen mutta eivät jää lainkaan päälle, kumpikaan. Eikä nRF löydä kysesitä TAGia lainkaan. Samanlainen ledien vilahdus tapahtuu kun painan pelkkää R-nappia. Samainen ledien vilahdus näkyy myös patterin vaihdon yhteydessä. Hieman näyttäisi siis siltä että B-nappi on viallinen.

Onko mitään tehtävissä vai onko tämä TAGi tuomittu vanhan firmikseensä vangiksi?

Google translates as:
Started updating my tags and it worked fine as instructed. However, one TAG refuses to go into update mode at all.

When I press the B + R buttons, the first LED flashes first and then the second one, but they don’t stay on at all, either. And the nRF can’t find the TAG in question at all. A similar flash of LEDs occurs when I press the R button only. The same flash of LEDs is also seen when the battery is replaced. So it would seem a bit that the B button is faulty.

Is there anything to do or has this TAG been convicted of imprisoning its old firmware?

The carefully executed precise sequence is
Hold B button, tab R(reset).

You can determine there version of the firmware using NFC tools. Down load it to your mobil, start it, tape read tag. Then hold it very close the the “ruuvi” one the board

please report back you results and the version.

I think I was pressing those buttons correctly because I was able to update all my other 8 TAGs. Just this last one won’t update.

SW Version for this TAG is 1.2.12. Is it so old version that it can’t be updated at all? :frowning:

I expect it should be updatable the “easy way” but I don’t know the secret.
It can always be updated the “hardware way” i.e.with ruuvi dev board (including Nordic dev kit)

Device sounds very old, bu maybe the button is broken. You can also test button by connecting both ends/pads with a small wire or other conductive metal.



Tried to connect both ends of B-button. It still does same thing. Both LEDs are flashing once and then nothing happens. I guess B-button is not the problem. Something else must be broken in my TAG.

Most likely broken, buy new one