Ruuvi tag starting up


I have got a Ruuvi tag for development purposes which I have opened and identified the following: 
1) When powered on or if we press the Reset button, the LED blinks for 1-2 seconds. After that nothing happens. Is it expected?
2) I installed the Ruuvi station mobile app and tried to add tags but it was unable to discover.

Is there any way I can troubleshoot this or is there any way to do OTA firmware update to the tag?
I also verified using nRF connect mobile app to confirm that the ruuvi tag is not discovered.



Hello, can you do NFC scan of the tag?

If the tag was bought from our webshop and it has original firmware, the tag should blink green led roughly once per second and you should see it with Ruuvi Station app.

Thanks for the reply. I tried NFC scan too but it didn’t give any results. The tag was received from customer. May be I will check whether they have uploaded any other firmware. If I click the reset button, the LEDs display for around 1 sec and then go off.

If you can enter the bootloader by holding down B and tapping R you should be able to restore original firmware from In every case, if you’re developing I recommend that you get Ruuvi Devkit or at least a TagConnect cable and something to program the tag with using wired connection.

Ignore the earlier message. I got the instructions from your link which I can try hopefully. Thanks.

I tried to make the tag enter bootloader mode. But even after holding the B button and pressing R button, it just displayed both LEDs for 1-2 seconds and nothing happened after that. I tried by scanning using nRF connect and it was not discovered.

Please check what kind of modifications your customer has done to the firmware, if any. In any case you can connect to the tag with a wired programmer.