Ruuvi Tag Pro does not go into bootloader mode

Ruuvi Tag Pro does not go into bootloader mode when I press the single button on the plate.

Battery out and back in did nothing except reboot. Battery still has enough voltage.

The Ruuvi Tag Pro works fine otherwise, so I just can’t update it.

Oder auf Deutsch…
Mein Ruuvi Tag Sensor Pro lässt sich nach drücken der entsprechenden Taste, nicht in den Bootloader Modus versetzen. Batterie hat genug Spannung.
Der Ruuvi Tag funktioniert ansonsten sehr gut, ausser eben das ich ihn nicht updaten kann. :frowning:

Hey! Button should be pressed for at least 10 seconds to get sensor to bootloader mode. If you tried this then probably something is wrong with the button.

@otso is the any other way around this?

I have pressed the button even longer than 10 seconds. Removed the battery and put it back. Variant tried to press the button at the same time as inserting the battery. It has indicated that it is 0.5 seconds in bootloading. But it did not work either. :pensive:

@otso is the any other way around this? :sweat_smile:

Sorry for the late reply.

Does the led color change to red when you press the button? It’s possible that button itself is physically broken, but if the button works the led should start blinking red instead of green

The button does not seem to work. The LED does not change to red. Have a few other sensors where it worked. The LED turns red when the sensor boots up. Maybe there is a way to interrupt the boot process? But I think the button is defective.

Sorry about the trouble with the button. If you have metallic tweezers, you can touch both ends of the button to simulate a button press.

Alternatively you can contact and we’ll replace the tag with one that has a working button

No problem because of the trouble with the tag. As you wrote, I was able to use pointed tweezers to bypass the button and boot the tag. The update has worked. Thanks for the tip @otso !

1 Like