Ruuvi Gateway could not connect to internet anymore

Hi all, I put a Ruuvi gateway version A2-1 into operation at the end of September / beginning of October at a customer site. It collected data from 40 Ruuvitags and sent it via Ethernet to a self-hosted MQTT brooker from Mosquitto. There I received the data and processed and displayed it using Thingsboard Gateway and Thingsboard. The whole thing ran stably until the end of October. In the last months I could not take care of it, because I started a new job and now I had to realize that no data arrived anymore. The gateway belongs to a customer, so there was some delay until I could physically look at the gateway again. Now I had to find out today that the red LED of the GW’s flashes 5 times per second, so there are problems with the Internet connection. I tried different cables and different router/switch slots without success (other devices were running on the same ports/cables), I reconfigured the gateway several times, updated the FW to V 1.10.1, connected against a test broker, reset to factory settings and then reconfigure, all without success. I can complete the configuration, but as message I always get only “gw_status: offline” sent on the brooker. FW update also worked, so the GW must have connected to the internet. Connecting the gw over wifi it is the same, during configuration LED is green, shortly after finishing configuration it starts blinking 5 Times per Second. I had originally set the configuration to Auto Update. Can it be that an automatic FW update has brought the GW to a standstill? For me this is the only explanation while it suddenly stopped working, cause at the customer site nothing else had change, nor the powersupply neither the internet setup. I am grateful for any advice regarding possible source of error, etc.!

Thanks a lot in Advance & Many greetings
Rudolph

Hi,

Sorry about the problem.

There was a change in MQTT operation between v1.8.X which was shipped and v1.9.X. The MQTT data is now sent as Gateway receives advertisements instead of batches. There was also a change between 1.9.X and 1.10.X related to SSL certificates.

You can return to v1.9.2 by selecting “advanced” and “specify URL”, and entering v1.9.2 to the end of the download link:

You can also return to v1.8.3 in a similar way. After downgrade, be sure to enable only manual updates to avoid automatic reupdate.

v1.10.1 is still in beta so it’s possible that we have a bug related to MQTT. Thank you for the report, we look into it. Please ping me on Tuesday if I haven’t remembered to follow up.

@Alexey_Skvortsov ^ FYI

1 Like

Hey Otso,

Thanks a lot for your super fast response! I will try the tip with the downgrade in the next days and let you know if that helped.

Have a nice evening
Rudolph

Hey @otso, “next days” have unfortunately been delayed quite a bit… I tried it today, and it also started right, but then I lost connection to the gateway and setup-screen was gone. (Maybe it has also finished the firmware download), I wanted to downgrade to v1.8.3. After the setup-screen was gone I tried to reconnect to the gateway, now I have to type in a password. Since I never set one, is there a standard password? I did not find anything in the forum here or on your homepage. The github release notes say "Gateway has default admin user “Admin” and password ID printed to QR code on gateway. e.g. “AA:BB:CC:DD:EE:FF:00:11”, if I understand that right, the printed Mac Address is the password? but that did not work, or is the gateway in v1.8.3 not accessible via wifi at all and I have to use LAN? Thank’s a lot for any advice! Best regards, Rudolph

Hello Rudolph,

You can hold the button on Gateway for 10 seconds to factory reset the Gateway and connect to the Gateway over WiFi Hotspot “RuuviGatewayXXXX”. The Gateway does not ask for password when configuring over hotspot.

On version v1.8.3 configuring over LAN is disabled by default, you need to enable it in configuration. On version v1.9.X and upwards configuration is enabled, the byte string “AA:BB:CC:DD:EE:FF:00:11” is not a MAC address but it should work as the default password.

You can also configure your own password over hotspot if you want to. Settings are preserved when upgrading firmware, but on downgrade settings can be lost. Be sure to configure the Gateway with “manual updates only” to prevent automatic update to later version if you downgrade

Hello Otso,

thanks for the fast reply and all your Tips. I also never needed a password before when I wanted to connect to the gateway via WIFI-hotspot, but after the update I need one,
also when I do the 10 seconds factory reset:

Hello,

The WiFi password was in revisions 1.8.X to 1.10.X if I recall correctly. It is “12345678” for all Gateways

Hey,

thanks a lot for your help. That password did work.