Ruuvi Gateway: cannot connect, reconfigure or reset

Hi! I powered off my Ruuvi Gateway last Sunday. After I powered it again, it no longer provided data for Ruuvi Station. I recycled the power a couple of times and no change. I left it powered up for a week - last sync shown in Ruuvi Station is when it was disconnected.

I tried to enter the reconfiguration by pressing for a second the button under the power usb socket. Wifi does not show up. I tried again, many times, with or without cycling power: wifi does not show up.

I pressed the button for 10 seconds. Red light blinks one longer and one shorter time. Wifi still not showing up.

Regardless whether the ethernet cable is connected or not, the device does not show up in Ruuvi Station and I don’t know how could I access the Ruuvi Gateway configuration.

Are there any secrets to how one could access the device configuration except than short & long press of the small reset button?

Hello and sorry about the problem.

Long press of the button runs a factory reset on Gateway, it should be always giving hotspot after long press when Ethernet cable is not connected.

The gateway also should connect automatically to Ruuvi Cloud when Ethernet cable is connected. If connection is successful, the Gateway will have solid green led on.

If you are familiar with reading serial ports over USB, you can connect to Gateway with e.g. PuTTY or Minicom with 115200 baud rate and see bug logs. Also, if you send me a picture of the Gateway sticker I can look if I see anything in our Cloud statistics about the Gateway.

The next steps we can take are:

  • Please let me know how the LEDs are. Solid green, blinking yellow or something else
  • If you are familiar with USB serial ports, we can debug it further with serial logs
  • please send a picture of the Gateway sticker to


I have this same issue. When I received the unit, never had a hot spot. I plugged it into Ethernet didn’t work for days, then worked for a few moments. I tried long press for 10 seconds, with Ethernet disconnected and power cycled. Now I get green for a bit, then 4 red and one green light. This has never worked reliably for me since I opened the box. Please advise.

Really sorry for the late reply on this. We’re going to email you soon. There are several possible issues for abnormal behaviour. A bad power cable or adapter can also potentially cause weird behaviour.