Problem with nRF52 - maybe defective?

Hi guys,
I bought a Ruuvi DevKit. I used the nRF52 board a few times. Today I was flashing my ruuvitag with Espruino. The board has always worked, but today while flashing the error below was threw.

I started surfing on the internet, trying to understand what was not working.
I also tried to use the SEGGER J-Link Commander with the command nrfjprog --recover as recommended on the Nordic forum, but it was just failing.
After a while, the board started connecting and disconnecting continuously, even if the USB cable remained connected.
Now I just can’t use the board, since it can’t stay connected to my laptop for more than one/two minutes.
It seems to me a hardware problem, probably due to a defective board.
What do you think?

Are you using the same USB cable as previously?

nope, I tried different cables

Looks like a connection error to me, I’d guess that you need to tighten the zip ties a bit.

at the end it was just a connection error :man_facepalming:t2:

Good to know