Old ruuvitag firmware upgrade?

Hi, I have a ruuvitag I bought a couple of years back and want to use it now.
I might have upgraded the firmware years back but the instructions online dont seem to work for me now.
If I restart the ruuvi holding down the single button and release it immediately I get a green led and can connect with nrfConnect on a device called dfutarg and the green light turns blue.
It is not visible on the ruuvi station
If I hold the button for longer it goes through a series of routines, firstly all 3 lights flash in order then it changes to a red led
If I let go the button on any of the other seuqences it is not visible on nrf Connect and no led is on
I want to reset the ruuvi to the original settings or upgrade the firmware.
Any ideas?


If the tag has name “dfutarg” it’s really old, possibly prekickstarter or some kickstarter alpha tester version?

Have you tried updating it with nRF Connect, package https://github.com/ruuvi/ruuvi.firmware.c/releases/download/v3.30.4/ruuvitag_b_armgcc_ruuvifw_default_v3.30.4_sdk12.3_to_15.3_dfu.zip might work. If that package does not work, it would be easiest to update the tag with a wired connection, but that would require a Ruuvi DevKit.

If official update package doesn’t work and you don’t have the Ruuvi DevKit we’ll need to think about how the update would be doable

Is the devkit available? Hopefully not very expensive, I will probably go that route.

DevKit is available at https://ruuvi.com/products/ruuvitag-development-kit/ , although it is more expensive than a new RuuviTag.

Another approach would be to tinker with the DFU package generation at ruuvi.firmware.c/package.sh at 24cbe775b4a318caccff86e4531ff2ec70794b23 · ruuvi/ruuvi.firmware.c · GitHub .

It’s possible that your device has the Nordic default key used for signing or soft device 3.0.0.
Key file can be changed with --key-file argument and soft device 3.0.0 compatibility can be tried by adding 0x8C to sd-reg argument