Missing data in downloads and in web view station

Hi there, I noticed a discrepancy between the data i can download and see on teh web station, and what i see on my phone. Note that these sensors are on teh other side of the planet, so my phone does not show me blutooth derived data - only ruuvi gateway data.

Compare two plots:


Both nights the temperature dropped below zero. This tag quite regularly loses contact with the gateway, it’s quite distant, but on the first night shown here it managed to get one measurement through -0.8°C, I got an email alert and it shows on the app. I download the data and that single, important, data point is missing…it’s not in the file and it’s not shown on the ruuvi station on the web view (which is weird because that point was definitely there last 12h ago when I was looking on the station…

What gives?

We store every data point for 24 hours, and after 24 hours the data is downsampled to 1 data point / 15 minutes.

If you have less than 15 minutes of sub-zero temperatures, the data point might have been lost in downsampling.

Just to be sure it’s not a caching issue on the web station, could you please try signing out and then signing back in? That will clear the local cache.

Thanks, I tried sign out/sign in but it’s likely as Otso indicates.

A bit sad though, that when it’s the only data point over 3-4 hours, it still get’s deleted through the down sampling, and thereby I miss any even rudimentary indication of what was happening over those hours. Maybe that downsampling script could be improved so that it doesn’t remove isolated data points? It’s weird that I do see other isolated data points retained, which allow missing data to be inferred in places. Now I wonder how many other data outages I see in the file are not outages but rather holes through downsampling.


Downsampling always allows at least 1 data point per 15 minutes through, no matter how rare they are. e.g. if we receive only one data point per hour, all of them are stored.