Inaccurate readings


#1

Hi,
Using the default firmware my temp, humidity and pressure readings are wrong. See attached. Eddystone fw reports the correct temperature. Im sure it used to work ok, but then the battery died and I forgot about it.

Any ideas?


#2

Sounds like there might be an issue with BME280. Eddystone FW uses nRF52 temperature sensor.

Just to clarify: The original firmware worked well, until battery was replaced?


#3

From what I remember it worked ok. But I’ve been running the eddystone firmware for ages until the battery swap, then I thought I’d check out what was new with the other firmware.


#4

If you warm the tag slightly by holding it in your hand, does the temperature change a little bit only, or does it jump around like crazy? And humidity if you breath onto the tag?

I suppose you have tried ‘cold-booting’ the tag by removing the battery for a moment and then putting it back?

edit:

Actually… which exact firmware version are you using? The 2.x firmware uses ‘RAWv2’ (data format 5) which the ruuvi station app does not parse correctly yet I believe, at least not the one on play store


#5

Yeah it changed temp if I hold it. I’ve tried a cold boot

That’s using firmware 1.0.1. The 2.x ones don’t seem to work. The tag has the red led on permanently after flashing then


#6

So it definitely does respond to temperature changes. But it’s completely inaccurate.


#7

Please contact sales@ruuvi.com and we’ll see if the tag should be replaced under warranty