How can I enable polling?

I’ve been bitten by this bug that’s preventing results being pushed to my custom HTTP server.

I thought I’d try switching to polling instead, and I can see hints around the internet that a GET request to http:///history might return data.

However, when I try that I get a 302 redirect:

$ curl -v ""
*   Trying
* Connected to ( port 80 (#0)
> GET /history HTTP/1.1
> Host:
> User-Agent: curl/7.79.1
> Accept: */*
* Mark bundle as not supporting multiuse
< HTTP/1.1 302 Found
< Server: Ruuvi Gateway
< Location:
< Set-Cookie: RUUVI_PREV_URL=/history

Do I need to do anything to enable polling? Running firmware 1.9.2.

If you have enabled authentication (it’s by default), then all these apis are behind the auth wall. Easiest way around this is to turn off authentication, but you should do this only if you are using the gateway in a secure network to prevent malicious users from touching your gateway configuration.

I’ve created an issue about adding api key support to better support use-cases like this without having to turn off authentication.

1 Like

ahhh, thanks!

Ideally it’d be nice if the admin UI was behind auth, but I could make the read-only API unauthed. A token I can control for the read-only API would also work.

My network is fairly trust-worthy, so for now I’ll just make it all unauthed.