Grafana image - data points outside time range

Hi there,

Complete newbie here, so apologies if this info is somewhere else!

I have just installed the downloadable image to my Raspberry Pi 4 to make things easy and while my ruuvitags have been found, Grafana shows no data, just “data points outside time range”. I have searched for a solution without success and was hoping a savyy here would know where to start.

Hi,

Does your RPi have Internet connection to synchronize the clock? You can also try wider time ranges to see where (when) the data is.

Hi Otso,

Thank you for your reply! I have had it connected to the Internet via ethernet and without. I have tried to adjust time settings also. No matter what time range I choose, I get the same results. I can click on an individual tag and see a sort of “range” on the vertical axis (high/low), but no graphs are recorded and on all measurements I get the " data points outside time range".

Hi,

There’s two scenarios that come to my mind:

  • Something is wrong with the time synchronization of RPi. Can you check the system clock somehow? e.g. SSH in and check what date returns?
  • The data you’re seeing is actually whatever tags I had on at the time of making the image, have you checked that the MAC addresses of the tags match the MAC addresses you see with Ruuvi Station app?

Hi,

I tried to SSH in and it returns the same time stamp on multiple times:

Linux ruuvicollector 4.19.93-v7l+ #1290 SMP Fri Jan 10 16:45:11 GMT 2020 armv7l
Logging in at 15:55 on 12.01.2021.

Linux ruuvicollector 4.19.93-v7l+ #1290 SMP Fri Jan 10 16:45:11 GMT 2020 armv7l

This is probably the problem, I’d guess your data points are near Fri Jan 10 16:45:11 GMT 2020

How did you connect the RPi to WiFi? The hotspot on image hijacks all internet traffic until it has been configured if I recall correctly.

Hi,

I have tried to configure the Wifi via the WIFI setup page as explained here:

https://blog.ruuvi.com/rpi-gateway-6e4a5b676510

-but after doing this I keep losing the ability to login to the Grafana main page.
Am I supposed to be able to login to Grafana once both browser and RPi are on the same Wifi network via raspberrypi.local:3000?

Hi,

Yes, and raspberrypi.local (port 80) should work too. You could also try connecting directly to the LAN IP which you can find from your home router or with some IP scanner tool.

This is the output from

uname -a
Linux pi93graf 4.19.66+ #1253 Thu Aug 15 11:37:30 BST 2019 armv6l GNU/Linux
above is mine and it works fine on a pi zero