Fluctuating readings with Pro and old RuuviTag

I got my Pros last week. I took them and an older RuuviTag into use. Measurement accuracy looks good, as advertised. Thanks!

For some reason the readings received on my iPhone 8 sometimes fluctuate a lot, both with the Pros and the old one. The reception was good during the fluctuation. They all had v3.30.2 at that time. As far as I can tell, my other RuuviTags did not exhibit such fluctuation. They all have v3.30.4.

The readings collected by Ruuvi Gateway during that time all looked ok.

When I tried to update the new Tags to v3.30.4, for some reason one of the Pros did not react to the reset button at all. Odd. Must be faulty in some way.

Ruuvi-fluctuate

Here’s a picture of the fluctuation.

Thank you for the report.

This is first time when I see sensors behaving like that, to clarify;

The readings collected by Ruuvi Gateway during that time all looked ok.

So the issue is in iOS Ruuvi Station app displaying strange readings, station.ruuvi.com with Ruuvi Gateway shows correct data without fluctuations?

Yes, the issue is in the iOS Ruuvi Station App. I have not tried with Android. Ruuvi Gateway data at station.ruuvi.com is correct, without fluctuations. The graph shows how the temperature reading changes when moving the sensor from living room to freezer (+20 → 20 degrees). My App should be up to date.

I noticed a similar fluctuation in the acceleration reading, in iOS app. When I turned the Tag upside down, the reading fluctuated several times between the old and new reading before settling to the correct one.

One thing to add is that my iOS App is very sluggish, and I need to restart it every now and then to get something done. It reads from 15 Tags (13 old, mostly with 2 buttons, 2 Pros, and all but one running v3.30.4) has 525 MB of data. Somehow the App receives or interprets the received data wrong, perhaps.

Ruuvi-2.PNG

Here’s another picture from the other Pro. One curious point: there have been no temperature fluctuations since the ones 3 days ago. The acceleration fluctuations happened, however, today.

Could this have something to do with time stamping an old data? Did this happen after you synchronized the data or during on-line situation?

As far as I know the gateway only receives advertising messages and the time stamp and value are tied together. When synchronizing with App, older values are transmitted and depending on the protocol, payload might get mixed and value and time stamp may not match?

RuuviTagPro does not have a reset button.

Hold down the button for 5 seconds, release and tap again to go toDFU mode.

This fluctuation happened in real time, in the App, when the App was receiving the measurement values over the air.

I am confused. When I pressed the whatever button (the only button on Pro) for 10 seconds, a red led lit up, and I was able to update the FW via the App.

I my memory serves me well, this is what the App told me to do. I had no idea Pro is updated differently and I have no idea how I was able to update 2 Pros doing it the wrong way. I returned one because I was not able to update it.