Failed firmware update - now continuous red light

Hi, Having just received and set up my Gateway, I thought I’d try to update my original RTs to the latest firmware.
I located the tag in the Ruuvi Station app and used the app’s firmware update routine.
The tag went into boot mode correctly and showed the red led.
Update went on and then it said ‘device disconnected’. After that, the firmware update would start again but has not completed and the red led stays lit.
I then tried using the nRF Connect app and it connected OK to the RT and went through the update routine but did not complete, finally ending with ‘Error 8 (0x8) GATT CONN TIMEOUT’.

Is the RT bricked or is there a way to recover it and finalise the firmware load? Also, any idea why this would have happened? Is there a log written for the Ruuvi Station update process, as there is for nRF Connect? (NB - Using android).

Hey! Before releasing firmware update feature we’ve tried different scenarios of things get wrong way: killing app, removing battery or resetting sensor during FW update. None of these cases bricked any of the sensors. At least nRF connect was able to successfully fix failed FW. By default Ruuvi Station Android doesn’t keep any logs.

Do you remember FW version that was installed prior to update? Is it possible your RT has low level battery? What is your Android version?

@otso o you have any ideas for diagnostic or fix solutions?


nRF Connect should be able to finish the update process in every case, RuuviTag does not overwrite bootloader before new update is in successfully.

Please try it with nRF Connect, and if nRF Connect fails please send the nRF Connect log to


Is there solution for this problem? Same thing happened to me today when trying to update firmware.

As Otso said you should try nRF Connect.

Can you describe how it happen? Did you get any error while updating FW?

I first tried updating with the ruuvi app and it did one 100% update cycle, but after that stopped at 14%. At this point it lost connection. I tried couple of times but no success. It does not move from 14% and loses connection at some point. Same issue when trying to update with nrf connect.

Can you restart your phone and try again?

If it fails again please send nRf Connect log to

1 Like