Eddystone


#1

This topic is dedicated to comments and conversations about the following RuuviLab tutorial:

If you don’t see any comments yet, don’t be afraid to be the first one to contribute!


#2

Hi, I’m having trouble configuring me new tag, I want to use it as a beacon in a Geocaching setting (thanks I had a long email trail with someone about geocaching when trying to use a previous version of the tag!).

However I can’t seem to access the tag and am wondering what I’m doing wrong. I can definitely discover it and can access the URL showing me the temperature etc.

I’m trying to use the ‘Web Bluetooth Configuration Tool’ but the password page doesn’t seem to be responsive at all. I suspect it’s an issue with using bluetooth via the web but I suspect I’m not technical enough to know how to get that working! I’ve been specifically using Chrome.

thanks
Rich


#3

@Rich_Lloyd Probably something wrong with your Chrome’s Web BT settings… Did you try to reboot or to use a different computer/phone?

Try also the Android tool to make sure there is no problem with the Tag and its password.


#4

Hi Lauri, I’ve tried browser on the laptop and browser on the phone. I don’t have android, trying to use Windows. If I have no more luck I’ll see if I can beg/borrow an Android device. thanks Rich


#5

Hi Lauri, I have managed to get hold of an Android device and have installed the app nRF but it just keeps telling me I need to ‘Enable Nearby in Google Settings’ which doesn’t seem to exist! So I tried the web version instead and all I get is a search icon in the middle of the screen. All very odd but I’m no further on and have 3 tags sitting on my desk doing very little! It’s a shame there’s no Windows support too.

Thanks
Rich


#6

@Rich_Lloyd Did you flash the Eddystone firmware first? And are you sure you’re using the correct Android app?


#7

I’m getting the same thing. I follow the instructions carefully. I have flashed the new Eddystone firmware. Worked flawlessly. Then I connect to the Ruuvitag using nRF Beacon for Eddystone on my Android phone. I put the Ruuvitag in configuration mode by pressing button “B”. The red LED comes on. The app finds the Ruuvitag and the dialog box comes up to enter the unlock code, just as it does in the video. I enter the default code exactly as shown in the video 00112233445566778899aabbccddeeff and I can see in the background of the app that it seems to connect to the Ruuvitag as the same box comes up as shown in the video, but the dialog box pops up again asking me to Unlock Beacon (again) and it says I entered the incorrect unlock key. I made sure it was not a typo. I’ve tried at least 10 times, being extremely careful to type the unlock code. It always does the same thing.

I’m so frustrated! To get this close and then stuck on an unlock code.

Any help would be greatly appreciated.

Scott


#8

Hello Scott,

Your unlock code is correct, and code is not case sensitive on “nRF Beacon for Eddystone”.

Is you tag brand new or have you had the tag for some time? The password gets stored to flash and is not reset even by firmware update, so if you have had the tag for sometime and experimented with Eddystone eariler your code might be the original FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF (32 times F).

Also if you have changed the password, the password is the same one as you entered.


#9

Thank you for your reply Otso. I’ve had the tags for a number of months now. I ordered them during your Kickstarter campaign, but never got a chance to try them until now.

I tried the code of all F and that was not correct.

I finally gave up trying to use the Android app and used the web config link from your website. It immediately accepted the unlock code of 0x00112233445566778899aabbccddeeff. I wonder if it has something to do with the fact that the nRF Beacon for Eddystone app does not allow the user to enter “0x” at the beginning?

All I know is that it absolutely did not work using the Android app nRF Beacon for Eddystone (would NOT accept the unlock code), but it works every time on the web interface. I have updated the settings numerous times using the web interface without any issues.

Scott


#10

Hi - Just got my new ruuviTags and successfully uploaded eddystone firmwares. I’ve got three of these and I was able to connect two of them but one is not accepting any of default unlock codes. I’ve got few questions:

Question 1) How can we reset the password (if flashing does not reset it)
Question 2) I was planning to use the ruuviTag as detecting if someone (with bluetooth device) is in the room. What do you suggest is the best method - I would like these to work without proximi.io (which I could not found these beacons) as these would be part of embedded project.
Question 3) Is there examples to use ruuviTag’s GPIO pins and send information out if e.g. two pins are connected (e.g. if water is flood to floor and two pins gets connected).

Thanks! Looking forward to work on these nice gadgets :slight_smile:


#11

Hey!

  1. Using a proper flashing tool (Ruuvi DevKit for example) which actually can erase the flash.
  2. Espruino is the easiest and quickest.
  3. Espruino has many tutorials you can follow

FYI, we’re soon going to update the official Eddystone firmware. We’ll tweet about it.


#12

Hi. Thank you Lauri. I was able to get forward with these. Next I need to find if it is possible to add small motion sensor into GPIO pins to see if there is movement in the room. Is there some small example on using RuuviTag GPIO pins as triggers? (Being bluetooth beacon itself cannot notice if there is someone in the room?)

Looking forward for Eddystone firmware :slight_smile:


#13

You could take a look at how button is read in RuuviTag fw. Essentially you need to write an interrupt function, initialize pin interrupts and configure the pin, polarity and function to interrupt driver.

You might also be interested in using accelerometer as interrupt generator, I.E. look for knocks on. tag.


#14

Hi.
I am trying the both solutions:
Web configuration: I find the ruuvi tag after pressing B. But Password incorrect. (Tried both)
nRF Beacon for Eddystone cant find anything. Just dont show/scann or nothing…

What is the solution. I wold like to adjust the TX Transmition Power.


#15

I just tried the Eddystone from lab.ruuvi.com/dfu ,
and connected with nRF Beacon for Eddystone using password 00112233445566778899AABBCCDDEEFF. You need to either scan the tag with NFC or press button “B” to enter connectable mode.

Are you sure that the tag has not been previously used with Eddystone and password changed, the password is stored even across DFU updates.


#16

Hi.
I do not know the password. I have never changed it.
However, I con use the original firmware if i can adjust the Tx power.
Is there any possibilities?


#17

Updating tx power can be done by recompiling the fw with desired power, https://github.com/ruuvi/ruuvitag_fw/blob/351b1eb5b6ff9b9bb6f6f1b99c29ebc915710a18/ruuvi_examples/ruuvi_firmware/bluetooth_application_config.h#L11 .
Valid settings are -40, -30, -20, -12, -8, -4, 0, 4