Unable to connect Ruuvitag with espruino firmware


#1

Hello,

I have been able to flash and then connect with Espruino native IDE on windows 10, as it was really slow, i decided to disconnect unpair and re-pair. Unfortunately, I am unable to re-pair. I have tried to re-upload the firmware (tried the weather station first and it was working), it worked but I still can’t pair my windows 10 laptop with the Ruuvitag. Is there any way to perform a factory reset ?

The ruuvitag leds are blinking the following:

Both LEDs turn on and then the green led turns off followed by the red led, any idea of what this means ?

I tried another Ruuvitag, flashed it and it seems to work.

Thanks,


#2

The second ruuvitag worked but was showing in console: app_timer_start error 8 and after I disconnected, impossible to reconnect :s Any idea ?


#3

I have managed to re-upload the firmware by using another mobile device and it worked. I get the prompt however I keep having the β€œapp_timer_start error 8” displayed on the prompt. Created another topic for that matter.


#4

Do you mean Espruino command prompt?
Are you using Espruino 1.93?

Regarding the first tag, if red LED stays on on Ruuvi Firmware after inserting battery, you’re having a broken tag and we’ll replace it under warranty. If the red LED blinks , your tag is in RAW mode and working as it should.


#5

I have a problem like you said. On my RuuviTag weather station, eddystone and Espruino 1.92 firmwares working without problem. But if I upload Espruino 1.93 to my RuuviTag it’s uploading %100 and done but after upload process red led stay on and RuuviTag not advertising. If I press reset button after this RuuviTag automatically go to DFU mode without pressing B button. Red led stays on everytime and RuuviTag stuck at DFU mode.

Is my RuuviTag defected?


#6

You need to give time for the bootloader to finish processing after uploading Espruino.
RuuviTag checksums whole program, and it takes some time on Espruino. If your weather station works, hardware itself is ok.

Try uploading Espruino and give it some time (30 sec - 2 minutes) to finish the update after DFU has disconnected. Red LED should turn off and Espruino should start advertising soon.


#7

I am indeed using Espruino 1.93. Here is a screen capture of what is happening.

It happened on both my ruuvitag and once i disconnect them it is impossible to reconnect. Maybe it is coming from windows 10, I am gonna try on a raspberry pi 3 tomorrow.


#8

Thanks. Did you try to run the built-in led flashers?

Please report tomorrow how it went with Raspberry Pi, I’ll try to repeat and debug the issue if the problem remains


#9

After your reply I’m uploaded Espruino 1.93 to RuuviTag and waited ~15 min but red led still on and no advertising. I know I’m one of the first backer received RuuviTag. Maybe this information helps to solve problem.


#10

Thank you for the details. I’ve had Espruino 1.93 running on Kickstarter RuuviTags with no issue, I’ll try to repeat the problem.


#11

I can confirm Espruino is running fine on my ruuvi.


| |_ ___ ___ _ ||___ ___
| | -| . | _| | | | | . |
|
|| || |||||_|
|
| http://espruino.com
1v93 Copyright 2016 G.Williams
Espruino is Open Source. Our work is supported
only by sales of official boards and donations:
http://espruino.com/Donate

=undefined

=undefined

=undefined

onInit()
=undefined
{ β€œx”: 27.34375, β€œy”: 27.34375, β€œz”: 1015.625 }
{ β€œx”: 23.4375, β€œy”: 23.4375, β€œz”: 1011.71875 }
{ β€œx”: 218.75, β€œy”: -386.71875, β€œz”: 1023.4375 }
{ β€œx”: 316.40625, β€œy”: 449.21875, β€œz”: 742.1875 }
{ β€œx”: 105.46875, β€œy”: 66.40625, β€œz”: 808.59375 }
{ β€œx”: -562.5, β€œy”: -847.65625, β€œz”: 281.25 }
{ β€œx”: 27.34375, β€œy”: -285.15625, β€œz”: -855.46875 }
{ β€œx”: 292.96875, β€œy”: -753.90625, β€œz”: -74.21875 }
{ β€œx”: -82.03125, β€œy”: 11.71875, β€œz”: 3.90625 }
{ β€œx”: -378.90625, β€œy”: 574.21875, β€œz”: -1285.15625 }
{ β€œx”: 898.4375, β€œy”: -859.375, β€œz”: 843.75 }
{ β€œx”: 410.15625, β€œy”: -695.3125, β€œz”: 1546.875 }
{ β€œx”: 27.34375, β€œy”: -3.90625, β€œz”: 1011.71875 }
{ β€œx”: 27.34375, β€œy”: -11.71875, β€œz”: 1019.53125 }

I downloaded via dfu, and waited until I could see ruuvitag in Espruino ide.


#12

I have reinstalled the firmware on my ruuvitag and finally managed to connect via raspberry pi 3 using bluez 5.43 and the online web IDE. It seems to work fine. However impossible to install the web IDE locally (it worked once and then failed).


#13

After multiple tests, it is working fine. Using www.espruino.com/ide but also espruino hub along with node-red. Perfect.

I gave up using it with windows 10.