Trouble on first use

Hi Guys,
I have trouble we my ruuvi tag on first use.
Android device is setted with location, bluetooth and netwaork access.
Beacon is on and nearby notif is rised. But it not weather station notif, instead it pops ruuvi/setup notif/page.
So I tried t re-install weather station firmware. Connection, Upload and deconnexion goes alright but the led is still red and flashing almost every seconds… What’s wrong? any ideas ?


Hello, Are you using the “RuuviTag basic” without sensors? Weather station is not compatible with the basic ruuvitag, as weather station requires environmental sensors which are not present on basic version.

OK, It might come from this… I have tag with temperature sensor. Is it enough to use weather station ?

Hello, Temperature sensor is not enough for weather station by itself. You can configure the Eddystone firmware to send ETLM-frames which contain the temperature.

Wow, so I ran into the exact same problem and for a simple reason. The Ruuvi sends me to the config website and the very first example you tell us to do is use the simple weather station app. What you don’t tell us is that it only works for certain devices! Not a good first experience as I had to get to the forum to find an answer to a simple question. Anyways, that aside this is all looking good and I can see my first use coming up quickly.

Same thing happened to me but hopefuly I succeed to get it to work with Eddystone.

Me too. Backed a “temperature sensor” and now would appreciate newbie-friendly setup instructions.

Thank you all for the feedback. We’ll update weather station to support RuuviTag basics as soon as possible.

I’ll post here when the update is complete.

Sounds ideal, thanks.