Switching firmware from Weather station to Eddystone

The current version of the tag broadcasts weather info on a URL, I got to check that with Chrome on iOS. I am trying to switch the firmware now to Eddystone. I have followed the instructions on the setup page to boot the tag in bootloader but I don’t see any source named “RuuviBoot” to connect to. I have now tried both nRF Connect and nRF Toolbox. I also gave the web tool a try with no success.

I have tried to keep the boot button pressed while tapping the R button. This makes the red LED stay solid for a few seconds, not constantly. If I press only the boot button the green LED lits up for a short time. Any help would be great.


In nRF connect app I only see N/A (Eddystone) in the list which is non-connectable. So I assume that somehow I am not getting into the bootloader.

You’re trying to enter the bootloader mode correctly. The red LED will be constantly on in bootloader mode, so for some reason the “B” press has not been registered during reset. Please try again, personally I like to take the RuuviTag out of the enclosure when updating so I can press the buttons.

Hi @otso. I have taken the tag out and absolutely making sure I am pressing the button continuously. Still not successful in getting this to work. Tried cutting the power off from battery as well.

Thank you for the test @Maulik_Kataria.

It should not be possible to have a tag with defective bootloader and yet boot to weather station firmware, as the tag starts at bootloader and verifies the application CRC befor proceeding - this should not be possible if something was wrong with the SW on tag.

Only explanation I can think of is some kind of hardware fault: either the nRF52 is not connected to button or button itself is not properly soldered on board.

If you have access to multimeter, could you please check the voltage across the button? It should read ~3 V when button is not pressed and ~0 V when button is pressed.

If the button itself is faulty, it is possible to enter bootloader mode by shorting the B while pressing reset. I did this by setting my multimeter in current mode, measuring current across button and tapping reset.

We’ll send you a replacement tag if the button is faulty, but sending a new tag is not as fast as working around the problem.

Thank you for reporting the issue, I’m looking forward to hearing if the button was at fault. Once we have determined the cause of the issue we can improve the test process to avoid any more similar problems.


Hi @otso thank you for a detailed reply. I will ofcourse try my best to find a solution and do what you have suggested. Fortunately I do have a multimeter to give this a shot. I will come back to the thread as soon as I get time to do this.

Thanks! :slight_smile:

I tried to update the firmware today and faced the exact same symptoms. I think that both the buttons work since pressing only Boot does not light up the red led, only the green one after a small wait. But when I press the R button while pressing the B button it caused the red LED to light up instantly. Unfortunately it turns off in few seconds and the bootloader is never activated.


it sounds like your buttons are working properly and you’re trying to enter bootloader properly. Could you please verify that you only tap the reset while keeping “B” pressed?

That is what I tried first. I got the red light on but only for a few seconds.
After that I think I tried every possible combination of holding and tapping the buttons I could think of just in case something worked.

this was happening to me too - I found that keep pressing R+B and releasing until the red light stays on seemed to get it to work.

Any news about this one?

I have 3 RuuviTags (B4) with default firmware (not sure about the version).

All of them work nicely with the RuuviStation. 2 of them won’t go to bootloader mode. Same symptoms as described above.

Also it is not possible to change between url and accurate modes on those same two devices. Pressing the B button will only light up green led and the mode won’t change.

The 3rd tag went nicely to bootloader mode and I was able to update the firmware for that one. Also switching between accuracy and url mode works with that tag.

I have tried to boot the mobile phone and switched the BT on/off. Also tried the B+R combo several (tens) times, but the red led wouldn’t stay on for the two problematic tags.

There may be some kind of an issue on the circuit board then. Could you please contact sales @ ruuvi.com and we’ll check this order and issue more closely.

I got this sorted out. Thank you!