RuuviTag don't want to be updated :/

I started updating a few RuuviTags to 2.5.9 today and the first 4 or so went without problem, but then one of them started to misbehave. When I put it aside the next one worked again without problem, so I assume it’s just a stubborn device.

I used an iOS device since I already had everything loaded from a trial a few months ago.

I put the RuuviTag in bootloader mode and started to send the firmware (“Start”) . I noticed after a while that the log is filling with a lot of info, but the dots on the top where not showing any progress as they normally would. I tried a few more times with no success. Also changed the battery just to make sure. I moved on to another one which again updated without problems.

Later I noticed that I can’t even put the device in bootloader mode anymore, when powered on it would also stay with red LED on for a while (I thought I bricked it) but then would enter the normal measuring mode again by itself. This I could repeat.

Any idea what I can do about this device? I am not sure which firmware it is running, but it’s from an April 2019 order.

I also stopped updating the remaining 16 tags for now.



Hello Alexhk,

Sorry to hear that your tag has a problem. First thing to check is if it works with a fresh battery, if not contact for a replacement. Updating the rest of tags should be ok.