RuuviTag+ disconnecting before firmware upload's end


I cannot update the firmware of one of my RuuviTag+ : It’s constantly disconnecting from nRF Connect before the end of the firmware upload. I have tried with the Weather Station firmware and the BLE App Beacon firmware without any luck.
It stays connected up to 2-5% of the upload, after that the green led turns off, the red turns on and nRF Connect show “disconnected”
I have try with nRF Toolbox with the same result : No firmware update.
I also try keeping the B button press: No luck

My other 4 RuuviTag+ were updated without any issue, so I’m puzzled : Is th fith broken? Or some workaround to update?




Sometimes problems with BLE connections can be fixed by resetting the BLE on phone by turning bluetooth off and on again. Also removal / reinsertion of battery in tag might help.

Just try a removal / reinsertion of the battery on the Ruuvi and an Bluetooth on/off on my phone => Same result = disconnection at 2% of the upload.
Also try with my wife’s phone, same result…

Strange, what’s going on with this 5th?

At last I updated my fith tag using my tablet, and I may find out the issue :smile: : I don’t know why it happens with only this tag, but it seems the Mi Fit on my phone app interferes with the firmware update in some ways :confused:.
I removed it from my phone and the firmware update is successful :+1:.

Happy to hear that the issue is resolved, thank you for sharing the fix