No dfu mode after flash a code with Espruino


#1

Hello there,

My Ruuvitag+ doesn’t work after a few attempts to use code with espruino! First, I inserted the Ruuvitag+ in bootloader mode and uploaded the “Espruino_v2.00” firmware, than some code with espruino, for turn on and off the led. It was all right. Then, I tried this code:

var Ruuvitag = require(“Ruuvitag”);
Ruuvitag.setAccelOn(true);
var on = false;
setInterval(function() {
 on = !on;
 LED1.write(on);
 console.log(Ruuvitag.getAccelData());
}, 10);

Now, Espruino IDE fails to connect (remain in waiting) and also the Ruuvitag+ does not enter the bootloader with the B+R keys. Anyone can help me?

EDIT: here a video of the problem:


#2

Hello,

I ran your code on my tag, it worked without issues. Bootloader should never be accidentally corrupted no matter what application does, although it might be possible to craft an application that intentionally bricks the bootloader.

First thing that comes to my mind is: have you tested with new battery? Espruino programs with 100 Hz interrupts can be extremely power hungry and drain a battery in a matter of weeks or even days.

It’s also possible that the battery itself has been faulty.


#3

Hi Otso,

I received the Ruuvitag yesterday, so batteries are new. Anyway, I tried also to run the Ruuvitag defected with a battery of another Ruuvitag, but result it’s the same. In the video, a green led lights up, but usually no. With nRFconnect (or espruino), when I press the buttons on Ruuvitag, while searching the ID is shown sometimes. If I try to connect to it, Espruino remain in “Connection…” state, meanwhile nRFconnect try to connect and than disconnect automatically.


#4

Any solution? No way?


#5

Sorry for my delayed reply.

I haven’t been able to replicate the issue, however sometimes if there is a sports tracker app running
on your phone or other nearby phone it can try to update it’s own firmware.

Another point to consider is that the B must be pressed when R is released, if you press them simultaneously the tag might not enter bootloader.

I’ll check with the rest of the team for possible solutions


#6

Hello,

Could you try replicating the steps on another RuuviTag? This helps us to narrow down if the problem is in hardware or firmware and possibly find a solution. We’ll replace both tags under warranty if you end up having a second bricked tag.


#7

Hello,

tried the same code on another RuuviTag and it works without problems. What can I test to further narrow the problem?


#8

Hello,

I’d guess that there is some sort of issue with the hardware. We’ll replace the faulty tag under warranty, please email sales@ruuvi.com and @henri will sort it out.

Thank you for your patience and help with troubleshooting.