Constant red and cannot enter DFU


A bit weird problem here. One RuuviTag worked fine with the latest firmware but then without no apparent reason the red light came on constantly and RuuviTag app cannot connect it anymore. Troubleshooting done so far without help
• tried on a battery from working RuuviTag
• removing battery and putting it back
• trying resetting device and to enter DFU, but NRFconnect does not find it.

As an information that might be helpful, the electronics might have got a splash of water when rinsing the device with the lid not fully closed. Also, after reboot the red light blinks every 14seconds and then returns to constant red. This happens couple of times, and then red light stays on forever without blinking

I don’t have wired connection, but I think that might be the only solution to fix it. If somebody with access to devshield is willing to help, that is gladly welcome.

Thanks, Mikko


The constant red led on is a sign of self-test failure, if the tag cannot enter bootloader it’s probably something in the DC/DC, crystals or radio. 14 seconds blink could be the watchdog timer resetting the tag.

Thanks, so the recommendation is to trash to tag? Of course with proper electronic trash procedures.

If the tag has had a few days to dry and it won’t boot, then the tag probably won’t recover.
You can try to wash the tag with isopropanol and cotton swabs, be extremely careful to not get any inside the vent of BME280. That should clear out any salt or other contaminants which might remain on board, but if something has corroded washing the board won’t help.